Foro MMLink

Avisos
Vaciar todo

Mmlink no funciona


juandi1984
(@juandi1984)
New Member
Registrado: hace 4 meses
Respuestas: 4
Topic starter  

Buenas.
Acabo de realizar el montaje de un m贸dulo B en una r1200gsa Lc. No consigo que funcione 😩, no tengo c贸digos de error en la moto y la luz del arduino esp32 se enciende. Cuando activ贸 la aplicaci贸n reconoce el m贸dulo ( sale un icono de una moto en la parte superior). A trav茅s de motoscan me reconoce todos los movimientos de la ruleta. Pero no consigo que funcione 聽la aplicaci贸n con la ruleta. Algo m谩s que pueda revisar?
Muchas gracias.聽


Citar
Administrador
(@admin)
Miembro Admin
Registrado: hace 3 a帽os
Respuestas: 303
 

Hola, por lo que indicas el problema es que el Arduino no recibe la informaci贸n del CANBUS de la moto. Revisa el cableado de las se帽ales CANH y CANL, que haya continuidad y que no este cruzados los cables CANH/CANL. Si esta todo bien, quiz谩s sea el modulo CANBUS que est谩 defectuoso, a mi me ha llegado alguno as铆, puedes pasarme el enlace donde compraste el m贸dulo CANBUS?

Saludos,
Fran


ResponderCitar
juandi1984
(@juandi1984)
New Member
Registrado: hace 4 meses
Respuestas: 4
Topic starter  

Este es el enlace del que tengo instalado. https://www.amazon.es/dp/B07VG3Z9GT/ref=cm_sw_r_cp_api_glt_i_C91WBS6MKB7AXD47WX8H?_encoding=UTF8&psc=1

Primero instale uno de AliExpress y no le quite la resistencia, al probarlo funcionaba pero muy mal y dejo de funcionar. Lo sustitu铆 pensando que podr铆a ser el m贸dulo y puse este 聽otro de Amazon. Le quite la resistencia y despu茅s de instalarlo comprob茅 que todos los pines ten铆an continuidad. Como con el nuevo m贸dulo no llego a funcionar prob茅 con otro arduino a ver si el problema podr铆a venir de ah铆 y seguimos sin que funcione. Volver茅 a instalar otro m贸dulo de canbus a ver qu茅 pasa.聽
muchas gracias.


ResponderCitar
Administrador
(@admin)
Miembro Admin
Registrado: hace 3 a帽os
Respuestas: 303
 

@juandi1984 ok, prueba a ver con otro m贸dulo de CANBUS, entiendo que estas cargando el firmware correcto para el modelo B. Tambi茅n asegurate que quitas la resistencia correcta, la que esta entre los pines CANL y CANH (R2).


ResponderCitar
juandi1984
(@juandi1984)
New Member
Registrado: hace 4 meses
Respuestas: 4
Topic starter  

@admin si, el software me lo mandaste para el modelo B. La resistencia estuve viendo los v铆deos y la tengo bien localizada. Muchas gracias por todo


ResponderCitar
juandi1984
(@juandi1984)
New Member
Registrado: hace 4 meses
Respuestas: 4
Topic starter  

Tras cambiar el m贸dulo de canbus por otro nuevo y volver a comprobar todas las soldaduras, el equipo funciona perfectamente.

Muchas gracias por todo!!!

Que maravilla de sistema. Un gran trabajo por todo el desarrollo.


Administrador me gusta
ResponderCitar
Compartir: