Foro MMLink

Conexión bluetooth ...
 
Avisos
Vaciar todo

Conexión bluetooth intermitente

4 Respuestas
2 Usuarios
0 Me gustas
621 Visitas
(@arrobapunto)
Eminent Member
Registrado: hace 5 años
Respuestas: 26
Topic starter  

Buenas noches, voy con otra duda/problema.

Tengo todo el montaje hecho y también he cargado el firmware, la aplicación instalada en el móvil... vamos, todo a punto. Pero no funciona bien. 

Instalado en la moto, el móvil no siempre se vincula por bluetooth con MMLink. Y cuando lo hace (y aparece el icono de la moto en la barra superior) las acciones sobre la rueda BMW no siempre son reconocidas por el móvil. Y cuando las reconoce, a veces llegan todas de golpe, como si estuviesen 'a la cola' debido a las pruebas que he ido haciendo justo antes para ver si reaccionaba, y la aplicación se 'vuelve loca' respondiendo a esas instrucciones acumuladas.

Fuera de la moto, enchufando un cable usb, alimentado por un cargador de móvil, en el módulo arduino, éste se enciende y soy capaz de emparejarlo con el móvil por bluetooth. Pero es una conexión intermitente. Es decir, está unos segundos conectado (icono de la moto visible) y se corta (desaparece el icono) para volver a aparecer al instante... y así siempre.

Me pasa con dos móviles de diferente marca y distinta versión de android.

Tiene toda la pinta de no funcionar bien el modulo bluetooth del arduino, ¿os parece un diagnóstico correcto? ¿le ha pasado a alguien más? ¿alguna solución? Se trata del que se recomienda de AliExpress.

Un saludo y gracias.

 

 


   
Citar
(@admin)
Miembro Admin
Registrado: hace 6 años
Respuestas: 390
 

Hola, lo que te pasa fuera de la moto es normal. El Arduino espera recibir información del CANBUS una vez lo has encendido, si pasados 10 segundos no ha recibido ningún evento del CANBUS de la moto, asume que hay algún problema y se reinicia para repetir proceso de reconexión al CANBUS de la moto. Por eso tu ves que la app se conecta (icono de la moto), pero a los 10 segundos el Arduino se reinicia, lo que provoca que se cierre la conexión bluetooth, la app detecta ese cierre y vuelve a reconectar (es cuando el icono de la moto desaparece por un momento y luego vuelve a aparecer cuando reconecta).

Lo que te pasa cuando lo tienes conectado a la moto no me lo ha reportado nadie. Puede ser que sea problema del Arduino, pero tampoco descartaría algún problema del módulo CANBUS. Yo te recomiendo, si puedes, que cambies los dos módulos, así vas a tiro seguro, si no pues prueba primero con el Arduino y si te sigue pasando pruebas a cambiar el módulo CANBUS.

Saludos!


   
ResponderCitar
(@admin)
Miembro Admin
Registrado: hace 6 años
Respuestas: 390
 

También revisa que tienes bien todas las conexiones, que no haya alguna que no haga bien contacto y provoque que no llegue bien la señal de canbus, revisa sobretodo las conexiones y cables de las señales del canbus, tanto las conexiones en la parte de electrónica como la de los conectores del cable RDC.


   
ResponderCitar
(@arrobapunto)
Eminent Member
Registrado: hace 5 años
Respuestas: 26
Topic starter  

Gracias, voy a revisar las conexiones y probaré a ver. 


   
ResponderCitar
Compartir: