Foro MMLink

Spotify "no oficial" y MMLink 3.0  

Página 1 / 2 Siguiente
  RSS

Administrador
(@admin)
Miembro Admin
Registrado: hace 2 años 
Mensajes: 251
29/09/2019 12:51  

Como sabéis en la nueva versión 3.0 the motomedialink se ha cambiado el método de control de Spotify para usar el mecanismo oficial de integración, ya que el usado en versión 2.X no lo era y en algunos casos daba problemas. Este nuevo mecanismo de integración funciona tanto para la versión gratuita de Spotify como la de pago (Premium). Resulta que existe una versión "no oficial" de Spotify (ya me entendéis con lo de "no oficial") donde en ese caso este nuevo método de integración no funciona, básicamente porque por lo que he visto esa versión "no oficial" esta realizada sobre una versión de Spotify que aún no soportaba este método de integración.

Para los que tengáis esta versión "no oficial", y no os esté funcionando el nuevo método de control, hay una forma de activar el método anterior de control de Spotify. Para activarlo deberéis realizar los siguientes pasos:

1. Aseguraros que tenéis instalada la versión 3.0.1 o superior de la app MMLink
2. Cerrar la app MMLink si es que está abierta
3. Descargar el archivo mmlink.conf desde el siguiente enlace: http://www.motomedialink.site/files/mmlink.conf  (es un archivo de texto que simplemente tiene una entrada en la primera línea con el texto SpotifyOldMethod=1)
4. Copiar en la carpeta MotoMediaLink de vuestro teléfono el archivo mmlink.conf 
5. Volver a arrancar la app MMLink

Con esto se activa el modo anterior de control de Spotify, para aseguraros que está activado, podéis ir a la pantalla de "Ajustes->Acerca de..." de la app MMLink y verificar que debajo del botón de "Comprobar actualizaciones" os aparece el texto [SpotifyOldMethod].

Por otro lado, recordaros que para que este método funcione correctamente debéis activar la opción "Estado de emisión del dispositivo" en el apartado de ajustes de la app Spotify.

Saludos!

This topic was modified hace 1 año  3 times by Administrador

ResponderCitar
miss
 miss
(@miss)
Eminent Member
Registrado: hace 2 años 
Mensajes: 44
13/07/2020 20:41  

el metodo funciona con el spoty pirata pero no deja pausar la musica


ResponderCitar
Administrador
(@admin)
Miembro Admin
Registrado: hace 2 años 
Mensajes: 251
14/07/2020 12:17  

Hola, pues cuando se hizo pruebas en su día con otros compañeros la pausa funcionaba bien, nadie me ha reportado lo contrario. Si tengo un hueco ya miraré de probarlo de nuevo, pero en principio no ha cambiado nada.


ResponderCitar
ferdiii
(@ferdiii)
Active Member
Registrado: hace 1 año 
Mensajes: 7
09/08/2020 14:18  

Copiada esa línea SpotifyOldMethod=1  en la carpeta de mmlink y funciona el spotify "no oficial".

Es curioso que, aunque esa linea la he copiado debajo de la que tenía en esa misma carpeta para invertir el mando de volumen, esta función sigue sin funcionar.¿alguna sugerencia para solucionarlo?Gracias


ResponderCitar
Administrador
(@admin)
Miembro Admin
Registrado: hace 2 años 
Mensajes: 251
10/08/2020 19:10  

Puedes pasarme el contenido del fichero mmlink.conf a ver si veo algo que este mal? porque yo he probado lo de invertir direcciones del volumen y si que funciona correctamente.

Saludos


ResponderCitar
Markesino
(@markesino)
New Member
Registrado: hace 5 meses 
Mensajes: 2
19/10/2020 18:10  

Buenas tardes,

pues ya somos dos a los que le pasa lo de que no funciona "pausa" en spotify no oficial. Lo curioso es que en el terminal que utilizaba hasta hace poco funcionaba (con Android 10 QKQ1.190828.002), en un Xiaomi redmi 9

Pero en el que llevo ahora que es un blackview bv5500 plus con Android 10 no funciona, curioso...

This post was modified hace 5 meses  by Markesino

ResponderCitar
Markesino
(@markesino)
New Member
Registrado: hace 5 meses 
Mensajes: 2
20/10/2020 07:27  

Hola,

mis disculpas, funciona correctamente pausar música, simplemtne había sido un descuido mío al no activar "estado de emisión del dispositivo"...

Torpeza mía, ya está solucionado...

 


Administrador me gusta
ResponderCitar
Vespaygs
(@vespaygs)
Active Member
Registrado: hace 2 años 
Mensajes: 10
02/12/2020 15:28  

Hola! A mi tampoco me funciona, he probado de todo y ni pausa ni avanza ni retrocede canción. Old method puesto y Nada y la configuración de Spotify correcta, he probado con el oficial, el no oficial, versiones nuevas, viejas reinstalando desde cero tanto Spotify como mmlink y nada incluso he llegado a reestablecer el teléfono. El poweramp funciona bien y todo lo demás también. Un saludo


ResponderCitar
Administrador
(@admin)
Miembro Admin
Registrado: hace 2 años 
Mensajes: 251
03/12/2020 18:25  

Has activado en ajustes de Spotify la opcion "estado de emisión del dispositivo"? es importante que este activada, sino no funciona. Por otro lado, para saber si has puesto bien el parametro SpotifyOldMethod, mira de ir a la opcion "Acerca de..." en la opción de "Ajustes" de la pantalla principal de la app MotoMEdiaLink, y mira si te aparece el texto "[SpotifyOldMethod]" debajo del texto que indica la versión de la app, si no te sale ese texto es que no esta cogiendo esa opción desde el archivo mmlink.conf, en tal caso revisalo.


ResponderCitar
Vespaygs
(@vespaygs)
Active Member
Registrado: hace 2 años 
Mensajes: 10
03/12/2020 18:39  

Si , el estado de emisión está conectado y en ajustes  debajo de comprobar actualizaciones me sale [Spotify old method]. Lo he probado todo y nada. Ahora estoy haciendo pruebas y de momento no he conseguido nada. Seguiré haciendo pruebas pero ya no me queda mucho por probar ☹️


ResponderCitar
Administrador
(@admin)
Miembro Admin
Registrado: hace 2 años 
Mensajes: 251
03/12/2020 18:50  

Pues es raro que no te funcione, en todo caso en siguiente versión he cambiado método para controlar app de música, para usar un mecanismo diferente que me permite añadir otros reproductores de música de forma más fácil. Esta versión espera sacarla para finales de mes. En todo caso si estas interesado te puedo pasar versión "beta" y así la pruebas. Ya me dices.


ResponderCitar
Vespaygs
(@vespaygs)
Active Member
Registrado: hace 2 años 
Mensajes: 10
03/12/2020 19:11  

Por mi perfecto, te envío un video enseñándote el problema a ver si damos solución a otros compañeros y si quieres me envías la versión beta


ResponderCitar
Vespaygs
(@vespaygs)
Active Member
Registrado: hace 2 años 
Mensajes: 10
09/12/2020 09:18  

Hola a todos! Al final detecte tras muchas pruebas el origen del error que me daba y que no me funcionaba correctamente el reproductor Spotify. Solo había que poner en ajustes / desactivar WiFi /la opción "SI". A mi me funciona bien así, por si algún compañero le pasa lo mismo y poniendo esta configuración lo puede solucionar. Un saludo a todos. 


ResponderCitar
Campeon
(@campeon)
New Member
Registrado: hace 3 meses 
Mensajes: 2
11/12/2020 06:38  

Ami me funciona perfectamente 


ResponderCitar
Vespaygs
(@vespaygs)
Active Member
Registrado: hace 2 años 
Mensajes: 10
12/12/2020 11:47  

Ayer y hoy después de 7 días ha vuelto a las andadas, no hay manera, vuelve a no responder y lo que pensaba que era de apagar el wifi, no funciona. Seguiré insistiendo a ver si consigo dar con la solución. 😪  😓 


ResponderCitar
Página 1 / 2 Siguiente
Share: